[Xenomai] ipipe-4.14: planned release date

Virendra Kate virendrakate at gmail.com
Thu Mar 28 01:32:43 CET 2019


>>> Did you all get an update on this issue ? Was it resolved after all? I
have
>>> the exact same hardware with the exact same issue. The board keeps
resetting
>>> after "Loading initial ramdisk..."
>>>
>>> My Setup is as follows:
>>> ipipe version: ipipe-core-4.14.89-x86-2
>>> Linux-kernel version: linux-4.14.89
>>> xenomai version: xenomai-3.0.8
>>> Hardware: AMD® Ryzen embedded v1756b
>>>
>>> The board works fine with Linux kernel 3.9.146 patched with the
appropriate
>>> xenomai-ipipe files. I would like to move to linux-kernel_4.14 as the
GPU
>>> driver is officially supported by AMD for linux-kernel_4.14.
>>>
>>
>> No direct progress regarding Ryzen, but I will try to glue together a
new 4.14
>> version if pending patches soon so that you can try if that happens to
help.
>> Will let you know.
>>
>
>Just done, see https://gitlab.denx.de/Xenomai/ipipe-x86/

The same issue persists.

1. I downloaded the kernel-patched with ipipe from the above link.
2. Added the co-kernel using: ../xenomai-3.0.8/scripts/prepare-kernel.sh
--arch=x86_64
3. Made the appropriate kernel config changes.

I have attached my .config file.

Thanks,
Virendra
-------------- next part --------------
A non-text attachment was scrubbed...
Name: .config
Type: application/octet-stream
Size: 211735 bytes
Desc: not available
URL: <http://xenomai.org/pipermail/xenomai/attachments/20190327/8e11f0f3/attachment.obj>


More information about the Xenomai mailing list