[Xenomai] Build Xenomai Lib native on the Beaglebone Black

Flavio Castro Alves Filho flavio.alves at gmail.com
Mon Mar 10 15:57:50 CET 2014


Hello Gilles,

It worked :-)

Thank you.

Flavio


2014-03-10 3:49 GMT-03:00 Gilles Chanteperdrix
<gilles.chanteperdrix at xenomai.org>:
> On 03/10/2014 04:00 AM, Flavio Castro Alves Filho wrote:
>> Hello,
>>
>> Does anybody tried to build the Xenomai user space native on a BeagleBone Black?
>>
>> I'm using Debian on my board, with the build-essential package installed.
>
> If you do not use xenomai 2.6 git, you will probably need this patch:
> http://git.xenomai.org/xenomai-2.6.git/commit/?id=b10527ed14399a6485f69b935988d9d5211066d0
>
> to allow compiling xenomai for the armhf flavor of debian.
>
>>
>> Should we have the same result as cross-compiling?
>
> With the same versions of the tools, you should have exactly the same result.
> Only, you will probably get it after some more time.
>
> Regards.
>
> --
>                                                                 Gilles.



-- 
Flavio de Castro Alves Filho

flavio.alves at gmail.com
www.linuxembarcado.com
Twitter: http://twitter.com/#!/fraviofii
LinkedIn profile: www.linkedin.com/in/flaviocastroalves




More information about the Xenomai mailing list