[Xenomai] SPI tx underflow interrupt not available

Reitinger, Peter preitinger at carl-valentin.de
Wed Aug 27 09:48:39 CEST 2014


On 08/26/2014 04:24 PM, Reitinger, Peter wrote:
> Dear Xenomai people,
>
>
> I am currently trying to write an SPI slave rtdm driver with fifo and dma support. I would like to receive an interrupt if there is an underflow in the tx fifo.
>
> Therefore I try to request the related hardware interrupt (which is irq 125 at my emtrion board which has EDMA and 2 McSPI interfaces where I am trying McSPI1).

Are you sure the irq number is 125? If 125 is a "physical" irq number,
it is almost probably not the number you should pass to
rtdm_irq_request. Have you tried requesting it as a Linux interrupt?



>
> Unfortunately it seems that interrupt 125 is reserved by another linux
driver because a list of /proc/irq/125 shows:
>
> root at dimm-am335x:/proc# ls /proc/irq/125
> 53100000.sham  spurious

Have you tried grepping "sham" in the kernel sources?

No, I am absolutely unsure if 125 is the right number because I am relatively new in programming interrupts in the kernel. So I feel I have to read a lot about interrupts in linux? So I have to combine original linux kernel function calls and xenomai function calls to get interrupts working? Sorry that I have so few experience there... If you have a quick help in mind even though it is not directly related to Xenomai, you would help me a lot... :-/

Thx, I will try to grep for sham. I am afraid there might be a lot of hits...

Kind Regards,
Peter Reitinger



More information about the Xenomai mailing list